Serato SL3 recording quality terrible

muzzadj

POW!
VIP Junglist
Messages
9,231
Likes
222
#1
I'm running the line out from the Booth output on my Xone 42 into the Aux of my SL3 box and I have to have the volume turned pretty much right down on my Booth knob on the mixer and raise it elsewhere and it just sounds muddy as hell.

I would normally record through my M Audiophile 2496 soundcard in my desktop but I have barely touched it since installing Windows 8 on it and now it can't seem to read the signal or even have the option to choose the line in on the soundcard.

Think i'm going to just have to buy myself a little USB interface for my laptop come payday on Friday. Its that or wait for Windows 8 drivers for my soundcard... Sick of this shit!

My question then I guess is does anyone here succesfully record through Serato?
 

ThePapa

Suffragette City..
VIP Junglist
Messages
8,291
Likes
659
#2
It's very shit and quiet I have no idea why they bothered. Can't you run Windows 8 in compatibility mode or something? Not that I even know what that means.
 

muzzadj

POW!
VIP Junglist
Messages
9,231
Likes
222
#3
It's very shit and quiet I have no idea why they bothered. Can't you run Windows 8 in compatibility mode or something? Not that I even know what that means.
Not too sure, I guess I would have to make it so my soundcard thinks its using Windows 7 if that's even possible.. I'm no tech wizard unfortunately. Windows 8 seems like it was a bad idea now. I don't even use my desktop but set it up to use the soundcard for this mix and now that's not even working properly!
 

Forau

CONCUSSION RECS
VIP Junglist
Messages
4,801
Likes
270
#4
Download ASIO drivers for your soundcard. Pretty sure they should work.


But first thing to try would be grab the driver install .exe file, right lick -> Properties - > Compatibility tab -> Run In Compatibility mode for windows 7 (if that doesnt work try XP).
 
Top