Serato SL3 recording quality terrible

Discussion in 'DJ's, MC's & Turntablism' started by muzzadj, Jun 5, 2013.

  1. muzzadj

    muzzadj POW! VIP Junglist

    Joined:
    Dec 29, 2007
    Messages:
    9,230
    Likes Received:
    222
    Location:
    Hurstpierpoint- Near Brighton
    I'm running the line out from the Booth output on my Xone 42 into the Aux of my SL3 box and I have to have the volume turned pretty much right down on my Booth knob on the mixer and raise it elsewhere and it just sounds muddy as hell.

    I would normally record through my M Audiophile 2496 soundcard in my desktop but I have barely touched it since installing Windows 8 on it and now it can't seem to read the signal or even have the option to choose the line in on the soundcard.

    Think i'm going to just have to buy myself a little USB interface for my laptop come payday on Friday. Its that or wait for Windows 8 drivers for my soundcard... Sick of this shit!

    My question then I guess is does anyone here succesfully record through Serato?
     
  2. ThePapa

    ThePapa Suffragette City.. VIP Junglist

    Joined:
    Aug 19, 2010
    Messages:
    8,293
    Likes Received:
    662
    Location:
    West London
    It's very shit and quiet I have no idea why they bothered. Can't you run Windows 8 in compatibility mode or something? Not that I even know what that means.
     
  3. muzzadj

    muzzadj POW! VIP Junglist

    Joined:
    Dec 29, 2007
    Messages:
    9,230
    Likes Received:
    222
    Location:
    Hurstpierpoint- Near Brighton
    Not too sure, I guess I would have to make it so my soundcard thinks its using Windows 7 if that's even possible.. I'm no tech wizard unfortunately. Windows 8 seems like it was a bad idea now. I don't even use my desktop but set it up to use the soundcard for this mix and now that's not even working properly!
     
  4. Forau

    Forau CONCUSSION RECS VIP Junglist

    Joined:
    Dec 2, 2010
    Messages:
    4,801
    Likes Received:
    270
    Location:
    Room 2 @ Fabric
    Download ASIO drivers for your soundcard. Pretty sure they should work.


    But first thing to try would be grab the driver install .exe file, right lick -> Properties - > Compatibility tab -> Run In Compatibility mode for windows 7 (if that doesnt work try XP).