Serato - Mono Signal From Both Decks

Discussion in 'DJ's, MC's & Turntablism' started by muzzadj, Mar 4, 2013.

  1. muzzadj

    muzzadj POW!

    Joined:
    Dec 29, 2007
    Messages:
    9,247
    Likes Received:
    220
    Location:
    Hurstpierpoint- Near Brighton
    Just set my decks up for the first time in ages and i'm only getting a mono signal through both decks in Serato. Anyone have any idea why? Last time I had a mix before this 1 of the decks had this problem and with a little fiddle with the cable going into the soundcard it would be sorted. But now it's happened to both decks and i've fiddled harder than Fritzl and still no luck :( Passionate hate for Serato these days. NEVER seems to work properly. Help?!
     
  2. rj_dnb

    rj_dnb Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    1,185
    Likes Received:
    241
    Ahh join the digi hate club :) I had problems last week. If fiddling with the RCAs didn't do anything try a different channel on the mixer. Although if its on both decks it suggests it might be the soundcard - there's a little switch on the serato box, make sure that's on whatever it needs to be too
     
  3. Shatner's Bosom

    Shatner's Bosom murder TANMUSHIMUSHI

    Joined:
    Apr 18, 2012
    Messages:
    4,833
    Likes Received:
    1,142
    Location:
    Hummus
    Yeah check the switchs on the box, I had the same problem and thought my RACs were knackered but i turns out one of the needles wasnt straight, seems obvious but make sure they are tight enough and straight... .mmmm.. tight and straight