Problem with my monitors (KRK)

Discussion in 'Production' started by IFTN, Aug 30, 2013.

  1. IFTN

    IFTN Active Member

    Joined:
    May 29, 2011
    Messages:
    344
    Likes Received:
    37
    Location:
    Berlin
    So my KRKs had been in Storage for a few months while I was away, got back and turned them on and one didn't work (was incredibly quiet, like you have to put your head right up against the cone to hear it). Tried switching about all the cables and everything until I deduced the problem was with the speaker. Turned them off and gave up, then next time I came back to show someone and turned them on it worked!!

    Worked for a week or two then suddenly the same speaker cuts out (although it doens't quite cut out, just really really REALLY quiet, ), I tried turning it off and on again and sure enough that worked again.

    Just happened now for the 3rd time except now turning it off and on again isn't fixing it, any idea what this problem might be?

    Cheers
     
  2. DjCartel

    DjCartel Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    1,184
    Likes Received:
    166
    Location:
    surrey
    sounds like the amp is fucked. if i turn mine off while music is playing, there is about 1-2 seconds where its super quiet. im guessing thats the amp turning off, so maybe thats it? im no monitor expert tho!
     
  3. Dugg Funnie

    Dugg Funnie Well-Known Member

    Joined:
    Nov 11, 2012
    Messages:
    1,401
    Likes Received:
    238
    Have you contacted KRK about it? They'll probably be able to help you the most. You said they were in storage, what kind of conditions were they in; specifically, how much dust could have built up on them and how humid was the room they were in?
     
  4. IFTN

    IFTN Active Member

    Joined:
    May 29, 2011
    Messages:
    344
    Likes Received:
    37
    Location:
    Berlin
    just in my bedroom while i wasn't here! don't think it will have been particularly dusty or humid
     
  5. monokai

    monokai New Member

    Joined:
    Aug 31, 2013
    Messages:
    7
    Likes Received:
    0
    that is probably a problem with amp. I have passive speakers, and sometimes one is much quieter that the other. Then I have to turn the amp off and on again and the sound goes back to normal