Lag and Crackles on Logic Pro

Messages
15
Likes
0
#1
'Ello chaps!

This is my first post on the forum but looks like there is a lot of very good information here so will certainly be sticking around!

I just had a little question for you tech genies out there. I am running Logic Pro on my Mac Book Pro (2.4GHz Intel Core 2 Duo, 3GB 667MHz DDR2 RAM, and a couple of speedy external Hard Drives.) Everything runs smoothly with no latency or lag issues until I start to layer up my project with a fair amount of reverb channels, vst soft synths etc. Basically, once the CPU hits a certain load I begin to get out of synch issues, crackling, lag, the lot.

So I was wondering if there is any way to combat this without having to dish out for a whole new computer with a bit more of a punch. I have a vague memory of a producer friend of mine saying I need to grab myself an external soundcard. Is it possible for some of the audio processing to happen outside the box to take a bit of the workload off my laptop's CPU?

Any advice or knowledge in this area would be greatly appreciated and permanently absorbed! :)

SpecialGuest
 

Mania

i fukin wot m8
VIP Junglist
Messages
1,532
Likes
428
#3
get logic x if you dont already have it, and get some more ram if your lap if it allows it.

if you cant afford either of those options, learn how to use bounce in progress and track freezing, to keep CPU usage low.
 

dfault

New Member
Messages
14
Likes
2
#4
Increasing buffer size will stop the crackling and errors but will also increase recording latency. If you are recording you want the buffer size low but if you are just mixing it's best to set it to the highest setting. There is a low latency mode setting you can engage that bypasses all latency inducing plugins in the signal path of the channel you are recording on. An external soundcard has nothing to do with CPU load really except that they might actually increase the load depending on the complexity of the device (number of inputs and outputs) and the quality of the driver (software required to run the interface with the computer).

Reverb eats up processing power. If you use Space Designer try lowering the quality/sample rate setting on the plugin interface and check the "preserve length" setting.

If you have a bunch of audio channels Logic will often assign inputs to them automatically. Check in the mixer and set any audio channels you aren't using for recording to "no input" and that will reduce the CPU overhead.

If you are running a project and keep getting the system overload message make sure you have an audio track selected in the arrange page and not an instrument track. If you have an instrument channel selected it increases the load on the processor. Even if you aren't using any audio tracks it is a good idea to have one in the arrangement just so you can select it when you are playing the project.

Most importantly, read the manuals. They are over 2000 pages long yet there is tons of information that isn't even mentioned in them. If you haven't read them at all, you are in the dark. The more you know, the more fun it is to produce music.
 

RUSSLA

Technique
VIP Junglist
Messages
6,466
Likes
1,093
#5
If you have a bunch of audio channels Logic will often assign inputs to them automatically. Check in the mixer and set any audio channels you aren't using for recording to "no input" and that will reduce the CPU overhead.
Is that really true tho? I can't see how that would make any difference but Im deffo guna try it (y)

- - - Updated - - -

To add, turn off an EQ analysers after you've used them, that kains CPU.
 

Gloxxy

I SNORT COAL
VIP Junglist
Messages
6,184
Likes
964
#6
I think the problem here is CPU and RAM limitations. More ram might alleviate the problem slightly but you are always going to run into syncing errors with that CPU and lots of channels running simultaneously.

You could try bouncing down channels that you've finished with lots of VST effects on to audio. Then using the audio channel instead of the channel with the VST instruments and effects on it. This will save a massive amount of processing power for your CPU.
 

lostnthesound

Burns Easily in the Sun
VIP Junglist
Messages
1,390
Likes
191
#7
Since your Mac is a Core 2 Duo, my assumption is that it's cir. 2010? Since your machine has 2 cores and uses 667 RAM vs the 1066 standard you'll be at a bit of a disadvantage in terms of the amount of tracks and CPU intensive plugins you can use in a given project. Please don't take that in a patronizing/disrespectful manner, that's certainly not my intent, the truth is that all machines are suseptible to Moore's Law.

As previously mentioned, freezing tracks, bus/send FX, increasing buffer size, etc. will definitely optimize your machine's performance.

Cheers.
 

Sulihin

Active Member
Messages
241
Likes
54
#9
Are you using an audio interface? If not, consider downloading ASIO4ALL drivers and that should also help quite a bit.
ASIO4ALL is a Windows thing, no?

My Macbook Pro was the first core 2 duo and it's way pre-2010. I can't install Mavericks on it.

I use Ableton and Reaper rather than Logic but the main thing to do is have an Audio interface, which at least perceptually seemed to double how many tracks and plugins I could have running and then freeze/bounce tracks once they're solid and move to others. Also make sure you're not running things like Chrome because they can suck up CPU just to spin flash ads.
 
Top