Audio Interface Setup


Drench Audio
VIP Junglist
May 21, 2007
Alright people,

about a month ago I bought an Alesis IO2, and have been using it with Reason, and it's been great, just switched the audio to IO2 and it worked.

But recently I've been trying to use it to record mixes with Adobe Audition and Ableton Live.

When in Audition, I change audio hardware to the IO2 and after changing that it won't let me click play or record, and doesn't play any files.

When in Ableton, I've got a choice of ASIO, MME & DX for the interface, I have tried all. On ASIO it says there is no audio engine, MME it doesn't record anything, and on DX, it records but audio cuts out every half second.

It's nothing to do with the buttons on the interface, as I can record in Windows Sound Recorder, and I have installed ASIO4ALL, and reinstalled the IO2 Driver.

Can anyone give me any advice on making the hardware work properly in terms of ASIO & DX etc.



Jun 9, 2008
Hi i have an alesis io2 running through a mac

there are known issues with this im afraid and they have never made a patch to fix :(

takes the piss i brought mine about 2 months ago and trawled the net for answers.And all i could find was there are several issues that if you have your pretty much screwed.
Top Bottom