1200s connections

Discussion in 'DJ's, MC's & Turntablism' started by DJNitrousUK, Feb 3, 2009.

  1. DJNitrousUK

    DJNitrousUK Active Member

    Joined:
    Jul 26, 2007
    Messages:
    6,079
    Likes Received:
    8
    Location:
    Norfolk, UK
    I thought it was my speakers, hence the thread I made, but I'm pretty sure it's my decks :(. I think the connections (audio) are dusty or worn because it seems really distorted and stuff but if I switch to line (CDJ) it sounds ok, help please?

    cheers ez
     
  2. Gloxxy

    Gloxxy I SNORT COAL

    Joined:
    Jan 30, 2007
    Messages:
    6,160
    Likes Received:
    949
    Location:
    TUT' MINES
    This happens quite often. You need the phono cables replaced.
     
  3. DJNitrousUK

    DJNitrousUK Active Member

    Joined:
    Jul 26, 2007
    Messages:
    6,079
    Likes Received:
    8
    Location:
    Norfolk, UK
    How much would this cost? They're not even that old either.
     
  4. RUSSLA

    RUSSLA DNBF Monarch

    Joined:
    May 23, 2008
    Messages:
    6,264
    Likes Received:
    884
    Location:
    BH1
    It sounds like you've just put the leads in the wrong place. Make sure everything is matched then you'll be ok. Hard to explain but if it sounds fine on Line, then were is your problem? It can't be your decks at all, think about it :)
     
  5. RUSSLA

    RUSSLA DNBF Monarch

    Joined:
    May 23, 2008
    Messages:
    6,264
    Likes Received:
    884
    Location:
    BH1
    ok jsut re-read your post... ignore what i just said
     
  6. slimbo011

    slimbo011 I've been naughty, I'm banned

    Joined:
    Aug 15, 2007
    Messages:
    1,130
    Likes Received:
    0
    Location:
    Gloucester
    its pretty str8 forward to replace the phono cables. jus a bit of solder and care
     
  7. DJNitrousUK

    DJNitrousUK Active Member

    Joined:
    Jul 26, 2007
    Messages:
    6,079
    Likes Received:
    8
    Location:
    Norfolk, UK
    Do I just buy some cables off ebay or whatever and fit them? Cheers sounding like a n00b at the moment.
     
  8. Textbook

    Textbook BUTTER

    Joined:
    Aug 20, 2008
    Messages:
    1,785
    Likes Received:
    3
    Location:
    Kernow'
    happened to mine a while back, first my left deck went so i got that fixed everything went peachy for a while. Then the right one went. i haven't had the time to go and get this one fixed yet so they're sitting there gathering dust at the moment.

    cost me around 20 pounds i think.
     
  9. muzzadj

    muzzadj POW!

    Joined:
    Dec 29, 2007
    Messages:
    9,247
    Likes Received:
    220
    Location:
    Hurstpierpoint- Near Brighton
    Holy shit i think this is the answer to my 6+ months of what i thought must be mixer problems!..

    Basically one of my decks cuts out and goes quiet/distorted and i have to whack the gain up and then back down to normal to fix it.. then it will do it again sometime later on..

    But then i think it can't be the decks because when i switch it up with the channels on my mixer its always channel 2?! Ahh my decks hate me lol
     
  10. Textbook

    Textbook BUTTER

    Joined:
    Aug 20, 2008
    Messages:
    1,785
    Likes Received:
    3
    Location:
    Kernow'
    I think mine were x club decks, i don't use them that much as i usually mix down my mates.

    may just give them to the Mrs.

    never had any other problems with them though.